WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20732 closed defect (bug) (invalid)

Slug Latin Characters

Reported by: rbaccaro Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.2
Component: Formatting Keywords: close
Focuses: Cc:

Description

When WP cleans the slug, it's also removing some latins characters instead of replace them, as "Ç" by "C" or "Ã" by "A" and so on. See attached.

Attachments (1)

Screen Shot 2012-05-22 at 2.37.27 PM.png (14.5 KB) - added by rbaccaro 2 years ago.
PS

Download all attachments as: .zip

Change History (9)

comment:1 SergeyBiryukov2 years ago

  • Component changed from General to Formatting
  • Keywords reporter-feedback added; needs-patch removed
  • Severity changed from critical to normal

Can you reproduce this on a clean install?

I get "Dissolução" converted to "dissolucao" in a post slug in both WordPress 3.3.2 and 3.4-beta4.

comment:2 rbaccaro2 years ago

For:

"Dissolução de sociedade e responsabilidade dos sócios na visão do Superior Tribunal de Justiça"

I got:

"dissoluo-de-sociedade-e-responsabilidade-dos-scios-na-viso-superior-tribunal-de-justia"

But not in a new fresh installation. I will keep you posted what could be.

Regards,

comment:3 rbaccaro2 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

On our installation, it's caused by Wordpress SEO plugin by Yoast.

Thank you.

comment:4 SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted

comment:5 rbaccaro2 years ago

  • Keywords close added

comment:6 kawauso2 years ago

  • Keywords reporter-feedback close removed
  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:7 kawauso2 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:8 rbaccaro2 years ago

  • Keywords close added

The plugin bug is also fixed with the 1.1.8 Version here
http://wordpress.org/extend/plugins/wordpress-seo/changelog/

The developer fixed right away. Thanks Joost.

Version 0, edited 2 years ago by rbaccaro (next)
Note: See TracTickets for help on using tickets.