WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#20758 closed defect (bug) (invalid)

Custom permalinks wreck pagination

Reported by: pushkin Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.3.2
Component: Permalinks Keywords: close
Focuses: Cc:

Description

My site is: http://golovegreece.com/

I can only get Permalinks to work in all scenarios – categories, tags, posts, pagination – only on Default setting. In Custom setting, I can get Permalinks to work for everything… except for pagination – when changing pages using 1,2,3 function – when a 404 error page comes up. In this case, the Custom setting is:

/archives/%postname%/

though I've noticed where I have 'archive's it doesn't matter what I have, it'll work – i.e. work except for pagination.

I have been through the support forums, the codex, gone through every relevant post on google and tried, without success, the following solutions:

  1. Renamed, deleted, recreated .htaccess file.
  2. 'Flushed' permalink settings.
  3. Tried a different theme.
  4. Tested permalinks on local server – Custom settings and pagination works fine on local server.
  5. Added plug-ins that claim to resolve issue.
  6. Deactivated all plug-ins.

I am on a Mac 10.4.11 using Safari and Firefox as browsers

Change History (16)

comment:1 scribu2 years ago

  • Keywords reporter-feedback added
  • Severity changed from critical to normal

when changing pages using 1,2,3 function

Maybe that function generates incorrect URLs. What do they look like?

Last edited 2 years ago by scribu (previous) (diff)

comment:2 pushkin2 years ago

Hello and thanks for getting back.

The URLs are as follows:

On Front Page navigation – located bottom left of my site's front page – using the Custom permalink, the URL comes up as http://golovegreece.com/page/2/. This leads to error 404.

With Default Permalink, the URL is: http://golovegreece.com/?s=athens&paged=2
(This works).

And when I use Search Site function, top right in menu bar – e.g. if I search for Athens – then with Custom permalink, the URL leads to http://golovegreece.com/page/2/. This is an error page.

While doing exactly the same search with Default permalink brings up the URL
http://golovegreece.com/?s=athens&paged=2. This works fine.

I should add that I've tried exactly the same process, with Custom permalinks, on a local server, and the above URLs – http://golovegreece.com/page/2/ and http://golovegreece.com/page/2/ – which cause 404 on the live site, work correctly. So, it appears to be a live site problem.

comment:3 scribu2 years ago

Does it work if you use semi-pretty permalinks, i.e. /index.php/archives/%postname%/ ?

comment:4 pushkin2 years ago

Do you mean if I put the following – index.php/archives/%postname%/ – into Settings>Permalinks>Custom Structure?

If this is what you mean, then it doesn't work. It comes up with a white page and 'No input file specified' in top left corner.

comment:5 scribu2 years ago

Yeah, that's what I meant.

So, what does your .htaccess look like?

comment:6 pushkin2 years ago

With Permalink settings on Default, .htaccess file looks like this:

# BEGIN WordPress

# END WordPress

When it's on Custom Structure, using /archives/%postname%, then .htaccess looks like this:

# BEGIN WordPress

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Permissions is set at 666 and GoDaddy is my hosting service.

comment:7 scribu2 years ago

Ok, I'm going to leave the reporter-feedback tag there, since we still don't have enough information to pinpoint the problem.

comment:8 pushkin23 months ago

Do you have any more ideas on this issue? Is there some further information I can provide you with that will help you resolve the problem? I would be happy to provide you with the access information to my site if you need to go into it to see if you find anything backstage.
Thanks

comment:9 scribu23 months ago

I am sorry, but this looks like a support issue. Try http://wordpress.org/support/forum/how-to-and-troubleshooting

comment:10 pushkin23 months ago

No, I'm sorry, I do not believe this is a support issue. Naturally, I tried the support forums before coming here. I spent a month asking various questions and trying out every possible solution. None of them have worked! Clearly, given the number of questions on the support forum regarding permalinks, Wordpress has a problem in getting these to work properly. This is a bug or structural issue and I would appreciate a resolution, otherwise it seriously diminishes the functionality of my site. I repeat: I am happy to provide you with any further details you require, including access to my site. Please advise as to the steps I should take to resolve this very important issue.

comment:11 scribu23 months ago

Clearly, given the number of questions on the support forum regarding permalinks, Wordpress has a problem in getting these to work properly.

The fact that people have trouble with pagination does not mean that they have the same trouble as you.

This is a bug or structural issue and I would appreciate a resolution

You have no basis to conclude that, since it is working on your local install.

I am happy to provide you with any further details you require, including access to my site.

I am sorry, but I do not have time to debug this issue for you. Perhaps someone else does.

comment:12 follow-ups: pushkin23 months ago

Actually, the exact problem I have with permalinks and pagination is widespread; so, yes, people do have the same problem and there is unquestionably an issue Wordpress needs to address.

Having tried every possible resolution to the issue provided by support and from here and given the amount of wordpress users experiencing similar problems, then I have every reason to suppose that there is a structural problem here.

If you are not willing to help, then why did you even bother to take the ticket? You're wasting my time as well as your own. How can I find someone more amenable? Should I start another ticket?

comment:13 in reply to: ↑ 12 SergeyBiryukov23 months ago

Replying to pushkin:

Actually, the exact problem I have with permalinks and pagination is widespread; so, yes, people do have the same problem and there is unquestionably an issue Wordpress needs to address.

Generally, problems with pagination come from a misunderstanding how query_posts() works (#16168, #16450, #19463, #19985, #20032 and others).

Since you have reproduced the issue with a different theme (have you tried Twenty Eleven though?) and all plugins disabled, this might not be the cause in your case.

Since pagination works fine on your local server, I suppose that your remote server is somehow misconfigured, which makes it a support issue.

Even though you haven't been able to resolve the issue through the support forums so far, that's still the most appropriate venue, until the exact bug is identified and confirmed by other contributors.

comment:14 in reply to: ↑ 12 helenyhou23 months ago

Replying to pushkin:

If you are not willing to help, then why did you even bother to take the ticket? You're wasting my time as well as your own. How can I find someone more amenable? Should I start another ticket?

Tickets here are meant to report and track progress of bugs (and their fixes), feature requests, and enhancements. They're not support tickets, as your statement seems to suggest you may believe. Opening another ticket will not help - it would (rightfully) be closed as a duplicate of this one.

comment:15 in reply to: ↑ 12 arieputranto23 months ago

  • Keywords close added; reporter-feedback removed
  • Resolution set to invalid
  • Severity changed from normal to trivial
  • Status changed from new to closed

Replying to pushkin:

Actually, the exact problem I have with permalinks and pagination is widespread; so, yes, people do have the same problem and there is unquestionably an issue Wordpress needs to address.

IMHO, nothing wrong with the permalinks and pagination in WordPress. You can abuse it to work whatever you like, as well as make it not working like the way you want. If you do understand how WP rewrite works, you should be able to debug it yourself.

I believe, you will find that the problem is not on the core. My questions are, regarding to your issue, how do you achieve your pagination? If you are using paginate_links(), what was the $args?

Please do check your theme once again.

comment:16 SergeyBiryukov23 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.