WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#20808 closed defect (bug) (duplicate)

„ character ("„", U+201E, double low-9 quotation mark) not cleared from url (slug)

Reported by: tometzky Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.2
Component: Formatting Keywords:
Focuses: Cc:

Description

A character "„" („, U+201E, double low-9 quotation mark) is not not cleared from slug and permalink url in %postname%.

It is very popular character in post titles in many European countries because it is used in smart quotes in MS Word and other text processors for example in Polish.

To reproduce:

  1. Go to http://demo.opensourcecms.com/wordpress/wp-admin/ and login as admin with passsword "demo123".
  2. Switch to "Month and name" in permalink settings.
  3. Create a post with a title of "foo „bar” foo"
  4. The post gets a permalink of http://demo.opensourcecms.com/wordpress/2012/06/foo-%e2%80%9ebar-foo/ which does not work.

Additional info:
Non-English usage of quotation marks
http://en.wikipedia.org/wiki/Non-English_usage_of_quotation_marks

Change History (1)

#1 @SergeyBiryukov
10 years ago

  • Component changed from General to Formatting
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.