WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#20817 closed defect (bug) (duplicate)

Email address not freed up after deleting network user

Reported by: GaryJ Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.2
Component: Users Keywords:
Focuses: Cc:
PR Number:

Description

  1. Registered a new user on the root site of a 3.3.2 multisite install with custom role of Copy-Editor (created via Members plugin).
  1. Before confirming, user wanted a different username, so tried creating a new user with correct user name. Correctly denied, as email address in use for an unconfirmed user.
  1. Got user to confirm account with incorrect name.
  1. Deleted user from site, and tried to creating a new user with correct user name. Correctly denied, as email address still in use for a network user who isn't linked to any sites.
  1. Deleted network user.

Now, here's where I think the bug is:

  1. Tried creating a new user with correct user name. Incorrectly given the message: "That email address has already been used. Please check your inbox for an activation email. It will become available in a couple of days if you do nothing."

Main issue is that I don't believe there is a pending or confirmed user with that email address in the system, yet the address is tied up somewhere.

Minor issue is the wording of the message - the email address in question does not match the site admin email, or the email address for the account I'm logged in with, so in most cases, it's never going to be "my" inbox.

Change History (2)

#1 @SergeyBiryukov
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Confirmed. Username is not freed up either, they both are left in wp_signups.

Going to close as a duplicate of #16001, where a "Pending Confirmation" users view is suggested.

#2 @GaryJ
8 years ago

Thanks Sergey - that's given me somewhere I can go look and fix it manually for now.

The idea of being able to view these pending users was going to be my follow-up ticket - clearly been a problem for others for a while :-)

Note: See TracTickets for help on using tickets.