Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#20823 closed defect (bug) (duplicate)

Main site's plugins not loaded on wp-activate.php in multisite mode

Reported by: rahal.aboulfeth Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.2
Component: Multisite Keywords: has-patch
Focuses: Cc:


In wordpress 3.3.2 ( also 3.4 and trunk ) when the site is installed as network mode, none of the main blog plugins are loaded on the user activation page.

This is important in case we use some plugin functions in the header or the footer ( like qtranslate for example ) , as well a various plugin widgets.

More importantly, plugins hooks can't work as plugins is not loaded.

There may be something I'm not grasping in the current behavior, but I made a patch to fix this.

Attachments (1)

load-plugins-on-activate.patch (1.0 KB) - added by rahal.aboulfeth 3 years ago.
patch made using hg-svn

Download all attachments as: .zip

Change History (4)

@rahal.aboulfeth3 years ago

patch made using hg-svn

comment:1 @scribu3 years ago

  • Cc scribu added

comment:2 @dd323 years ago

Duplicate of #18278 which is closed as a duplicate of #17948

comment:3 @SergeyBiryukov3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.