WordPress.org

Make WordPress Core

#20857 closed defect (bug) (fixed)

Failure to display admin menu on hover

Reported by: m0r7if3r Owned by: koopersmith
Milestone: 3.4 Priority: normal
Severity: normal Version: 3.4
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

In the latest release of WordPress 3.4 (21007), there is a bug with the admin menus. The reproduction steps are as follows:

  1. Expand browser to over 900px width
  2. Ensure menu is not collapsed
  3. Ensure you are on a page that has a pop-out
  4. Reduce browser width to 900px or less, thus causing the admin menu to auto-collapse (and removing the option of expanding it)

If you follow these steps, when you hover on the currently selected menu item, it will not display the child menu. I have confirmed this bug on multiple computers in the following browsers (assume latest version unless otherwise specified): Chrome 21, Chrome 19, Firefox 12, Firfox 13, Firefox 14, Opera 11, Internet Explorer 10, Internet Explorer 9, and Safari 5.1.7. I have also confirmed that the bug does not exist on WordPress 3.3.2 in any of these browsers.

Attachments (3)

20857.diff (578 bytes) - added by koopersmith 23 months ago.
20857.overlapping.png (4.4 KB) - added by SergeyBiryukov 23 months ago.
20857.2.diff (527 bytes) - added by SergeyBiryukov 23 months ago.

Download all attachments as: .zip

Change History (17)

comment:1 SergeyBiryukov23 months ago

  • Milestone changed from Awaiting Review to 3.4

Confirmed as well. Doesn't happen in 3.3.2.

comment:2 nacin23 months ago

Confirmed. Key point (which I missed at first) is "when you hover on the currently selected menu item".

comment:3 SergeyBiryukov23 months ago

Introduced in [20749].

koopersmith23 months ago

comment:5 follow-up: SergeyBiryukov23 months ago

Page refresh doesn't help, the flyout is actually never displayed for an active responsively collapsed menu item.

20857.diff fixes the issue, came up with exactly the same patch.

comment:6 in reply to: ↑ 5 m0r7if3r23 months ago

Replying to SergeyBiryukov:

Page refresh doesn't help, the flyout is actually never displayed for an active responsively collapsed menu item.

20857.diff fixes the issue, came up with exactly the same patch.

If you remove

.no-js

from

.no-js #adminmenu .wp-has-submenu:hover .wp-submenu,

on line 1340 (of 21007) the issue resolves itself, but I am not sure if that affects anything else, since it's a rather large amount of CSS. You could, alternatively, add a :hover after the CSS properties started on line 1734, which create the issue.

Edit: code for the second method (must go after line 1740)

#adminmenu .wp-has-current-submenu:hover .wp-submenu{display:block;}
Version 2, edited 23 months ago by m0r7if3r (previous) (next) (diff)

comment:7 azaozz23 months ago

  • Keywords commit added

Patch looks good.

comment:8 ryan23 months ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In [21012]:

Fix admin menu hover. Props koopersmith. fixes #20857

SergeyBiryukov23 months ago

comment:9 SergeyBiryukov23 months ago

  • Keywords has-patch added; commit removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

[21012] causes an issue when a browser window is wide, but short in height: 20857.overlapping.png.

Support forums topic with a video demonstration:
http://wordpress.org/support/topic/admin-sidebar-buggish-on-34-rc2-21036

20857.2.diff fixes that.

comment:10 nacin23 months ago

Yuck.

comment:11 azaozz23 months ago

  • Keywords commit added

Ah, so that's why the check was needed. Thought it was left over from when the submenu for the current screen used to pop-out too.

20857.2.diff works well, +1.

comment:12 nacin23 months ago

  • Owner changed from ryan to koopersmith
  • Status changed from reopened to reviewing

Going to ask koopersmith to review this as well.

comment:13 jane23 months ago

Not the issue that needs to be solved here but wo should think about for 3.5: the responsive collapse really shouldn't remove the ability for the user to expand the menu. If they would rather have it expanded, it should be up to them. If we really thought collapsed was the best UI, that's what we would have all the time.

comment:14 koopersmith23 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In [21065]:

Prevent hoverIntent from shifting open, expanded admin menus if the entire submenu is not visible. props SergeyBiryukov, fixes #20857.

Note: See TracTickets for help on using tickets.