Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#20868 closed defect (bug) (fixed)

Live previewing locks the iFrame window & URL

Reported by: jim912 Owned by: koopersmith
Milestone: 3.4 Priority: normal
Severity: normal Version: 3.4
Component: Customize Keywords: has-patch commit
Focuses: Cc:


When you switch themes using the "Save and Activate" button on a live-preview window, the iFrame stays persistent unless you move away from the theme panel. This can be a problem because:

1) The URL in the address bar stays as /wp-admin/customize.php?theme=xxxxxxxxx

This means you can't see the actual URL of where you are - possibly promoting phishing.

2) You can't live preview any theme you've previously previewed.

Steps for reproduction:

  1. Preview Theme X
  2. Click "Save and Activate"
  3. Preview Theme Y
  4. Click "Save and Activate"
  5. Try previewing Theme X again, but you will get a blank page now.

Attachments (1)

20868.diff (2.2 KB) - added by koopersmith 3 years ago.

Download all attachments as: .zip

Change History (9)

#1 @SergeyBiryukov
3 years ago

  • Component changed from Themes to Appearance
  • Milestone changed from Awaiting Review to 3.4

Confirmed both points.

The steps in point 2 result in a blank screen with a spinner image. No JS errors in the console.

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

#2 @SergeyBiryukov
3 years ago

Closed #20874 as a duplicate of point 1.

#3 @koopersmith
3 years ago

  • Keywords needs-patch added
  • Owner set to koopersmith
  • Status changed from new to accepted

Sounds like something's up with pushState. I'll add it to my list.

3 years ago

#4 @koopersmith
3 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

Patch should fix both of those issues. Also allows for events that have optional data.

#5 @SergeyBiryukov
3 years ago

20868.diff works. Tested in Firefox 12, Chrome 19, IE 8, Opera 11.64.

#6 @nacin
3 years ago

  • Keywords commit added; needs-testing removed

Marking for final review.

#7 @ocean90
3 years ago

Works for me too.

#8 @ryan
3 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In [21029]:

Customizer: fix stuck urls and preview white screens after repeated save and activates. Props koopersmith. fixes #20868

Note: See TracTickets for help on using tickets.