WordPress.org

Make WordPress Core

Opened 23 months ago

Closed 6 months ago

#20936 closed defect (bug) (worksforme)

Image upload - HTTP error

Reported by: voji Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.2
Component: Upload Keywords:
Focuses: Cc:

Description

Unable to upload some type of images, because crunching error.

Reproducation:
Try to upload attached png image (SC20120611-160917.png), to wordpress site (3.3.2). I try it all of my wp sites, and fresh installation (without plugins). The upload progress aborted (HTTP error).

If you convert the png file to jpg, the upload and crunching was succeed (there is no configuration errors i think).

I try some workarounds too, but doesn't help (this is not an individual problem i think):
http://wordpress.org/support/topic/http-error-on-image-upload-still
http://wordpress.org/support/topic/flash-uploader-logs-out-during-crunching-phase?replies=19

This error affected 3rd party tools (like android wordpress app).

Attachments (1)

SC20120611-160917.png (56.8 KB) - added by voji 23 months ago.
Image, for bug reproducation (screenshot created from wordpress app client site error)

Download all attachments as: .zip

Change History (9)

voji23 months ago

Image, for bug reproducation (screenshot created from wordpress app client site error)

comment:1 SergeyBiryukov23 months ago

  • Component changed from General to Upload

Tested the attached image on both 3.3.2 and 3.4-RC4, could not reproduce the issue.

2-year old workarounds for the Flash uploader probably no longer apply, since there's a new file uploader now (#18206) which uses HTML5 first and should fall back to Flash only in IE if Silverlight is not installed.

comment:2 voji23 months ago

I think this problem php/apache issue. On local installation i cannot reproduce this error.

The isp apache version always generate HTTP error with any png file upload.

The isp server phpinfo available here: http://voji.hu/phpinfo.php

comment:3 iridox23 months ago

Just out of curiosity, are you using WP_Smushit?

The Smush.it API has been really flaky lately, and if it fails all you see is a generic HTTP Error.

comment:4 voji23 months ago

  • Version changed from 3.3.2 to 3.4

Today i update my productive sites to 3.4. The problem still exist, but the HTTP error disappear (after png upload, the progress bar freeze with "Crunching…" state, and no thumbs generated).

I no use WP_Smushit (in my productive installation use only official plugins + Google Analyticator, and Google sitemaps).

I created a clean wp install on isp server, for testing purposes (currently waiting for dns modifications to apply).

Last edited 23 months ago by voji (previous) (diff)

comment:5 follow-up: SergeyBiryukov23 months ago

  • Version changed from 3.4 to 3.3.2

Version number indicates when the bug was initially introduced/reported.

comment:6 in reply to: ↑ 5 voji23 months ago

Replying to SergeyBiryukov:

Version number indicates when the bug was initially introduced/reported.

sorry

comment:7 voji23 months ago

The clean install is up and running, but the error still exists.

Apache error, php_error logs are empty.

comment:8 SergeyBiryukov6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Related: #19817, #22146, #22869, #23127, #23363, #24614.

No traction in 17 months, no clear steps to reproduce. Appears to be specific to the hosting provider. Feel free to reopen with more information if there's still a problem.

Note: See TracTickets for help on using tickets.