WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 9 months ago

Last modified 9 months ago

#20938 closed defect (bug) (worksforme)

Adding existing category duplicates default one

Reported by: hvsupr Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.3.2
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

In the post editing page, if you add a category which already exists, Wordpress duplicates the default category (Uncategorized), instead of showing a warning or doing nothing.

Attachments (1)

Screen shot 2012-06-13 at 11.40.21 AM.jpg (70.3 KB) - added by saltcod 22 months ago.

Download all attachments as: .zip

Change History (6)

comment:1 saltcod22 months ago

Confirmed in 3.3, seems fixed in 3.4rc4.

comment:2 SergeyBiryukov22 months ago

I can reproduce this in trunk. Seems that the last category in the list gets duplicated.

Also, seems to be a mere visual error, no new categories are actually created.

Couldn't reproduce on a clean install of 3.4-RC4 though, needs more investigating.

comment:3 DrewAPicture15 months ago

  • Component changed from UI to Administration
  • Keywords 2nd-opinion reporter-feedback added

Can't reproduce this on 3.5, nor on current trunk.

comment:4 andrewspittle9 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce this on 3.5.2 nor on current trunk. Followed these steps on both versions:

  1. Create category titled "News" at Posts > Categories.
  2. Create new post at Posts > Add New
  3. Add title and body content in to post
  4. Click "Add new category"
  5. Enter "News" as the new category name
  6. Click "Add new category"

Doing this selects the current "News" category that was created in step 1. It does not create a duplicate "Uncategorized" category.

comment:5 helen9 months ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.