WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#20962 closed defect (bug) (invalid)

Sanitization of post title for post_name in db

Reported by: flyerua Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Editor Keywords:
Focuses: Cc:

Description

Hello. Tell me please, why 3.4 completely removes "to" from post_title when sanitizing it for post_name field in DB?
For example, post title is (without "")
"Lupin III: Mine Fujiko to Iu Onna - Episode 11"
so now it produces
"lupin-iii-mine-fujiko-iu-onna-episode-11"
instead of
"lupin-iii-mine-fujiko-to-iu-onna-episode-11"
as it is supposed to do and as it was doing in 3.3 ?
Please fix it. Thank you

Change History (4)

comment:1 SergeyBiryukov22 months ago

Can't reproduce on a clean install. Make sure you have disabled all plugins.

comment:2 flyerua22 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Hmm, thank you, by turning off/on plugins one by one I found that this is cause by WordPress SEO by Yoast. Though this is weird.

comment:3 SergeyBiryukov22 months ago

  • Milestone Awaiting Review deleted
  • Severity changed from major to normal

comment:4 nacin22 months ago

Yep, this is WordPress SEO - it removes common words from URLs to make them more meaningful.

Note: See TracTickets for help on using tickets.