WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#20968 closed defect (bug) (invalid)

Wordpress 3.4 adds a space between a letter and an apostrophe

Reported by: djibs13 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: I18N Keywords:
Focuses: Cc:

Description

Since WordPress 3.4, when I published an article, WP automatically adds a space before the apostrophe. This poses problem in some languages​​.

For example (in french):

Je plonge dans l’océan (I dive into the ocean)

becomes :

Je plonge dans l 'océan

In HTML : Je plonge dans l 'océan

The problem is present in the title and body of the article (see attachments)

Attachments (2)

news.png (62.1 KB) - added by djibs13 3 years ago.
title.png (21.9 KB) - added by djibs13 3 years ago.

Download all attachments as: .zip

Change History (5)

@djibs133 years ago

@djibs133 years ago

comment:1 @azaozz3 years ago

  • Keywords reporter-feedback added; needs-patch removed

Can't reproduce with the default localization, no plugins and Twenty Eleven. Could you try removing the localization string and testing again.

comment:2 @djibs133 years ago

The problem was fixed that night. He was present in the translation file

the correctfi is:

http://svn.automattic.com/wordpress-i18n/fr_FR/branches/3.4/messages/fr_FR.mo

Thank you anyway for your help, I thought it was a bug

comment:3 @SergeyBiryukov3 years ago

  • Component changed from General to I18N
  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.