WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 2 years ago

#20988 closed enhancement (duplicate)

Open a closed sidebar box and enable droppable/sortable in it when you hover a draggable available widget over it

Reported by: ldebrouwer Owned by: ldebrouwer
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Widgets Keywords: needs-patch ux-feedback
Focuses: javascript Cc:

Description

At the moment you have to explicitly open a sidebar box to allow it to except available widgets. In my humble opinion this is bad UX and the sidebar box should expand automatically when being hovered over with a draggable and it should accept the draggable to it's containing droppable/sortable as well.

The obstacles to overcome:

  • Since the draggable in most cases overlaps the sidebar box when dragging over it ( unless you move really quickly ) it's hard to register a 'mouseenter'. This could be solved by setting the 'cursorAt' option for the draggable.
  • Opening a sidebar box is trivial but activating the droppable/sortable only seems to kick in when the draggable has been released.

Change History (3)

#1 @ocean90
5 years ago

  • Cc ocean90 added

#2 @ocean90
4 years ago

  • Focuses javascript added

With #25952 it's now possible to drop a widget on a closed area. Would be nice to have it open too to place the widget to the correct position.

it's hard to register a 'mouseenter'. T

Maybe hoverIntent can help here.

#3 @ocean90
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13524.

Note: See TracTickets for help on using tickets.