WordPress.org

Make WordPress Core

#21006 closed feature request (duplicate)

Image Rotation Fixer

Reported by: johnbillion Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Media Keywords:
Focuses: Cc:

Description

This sounds like something that should be in core: http://wordpress.org/extend/plugins/image-rotation-fixer/

Change History (3)

comment:2 nacin22 months ago

  • Milestone changed from Awaiting Review to 3.5
  • Owner set to azaozz
  • Status changed from new to assigned

I agree. Rotating an image based on the EXIF data is very smart, and I was surprised (when I last looked into this) that we didn't already do it.

I think azaozz has recently implemented this on WordPress.com, so he probably has a very good idea for how this can be implemented in core.

comment:3 dd3222 months ago

  • Milestone 3.5 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Implemented in #7042 and reverted/wontfix. Duplicate of #14459

I think azaozz has recently implemented this on WordPress.com, so he probably has a very good idea for how this can be implemented in core.

The main problem is the insane amounts of memry it takes to rotate the full size image, rotating the resized images should be significantly better.. And then there's the loss of Exif data from the uploader (My memory failed me), all covered in the above ticket

Last edited 22 months ago by dd32 (previous) (diff)
Note: See TracTickets for help on using tickets.