WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#21011 closed defect (bug) (duplicate)

WordPress + Multisite + IIS7, URL Rewrite bug with pagination and 'Older Entries' links causing 404

Reported by: sjlevy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Multisite Keywords:
Focuses: Cc:

Description

Using Multisite WordPress (3.3.2) on IIS7 with the standard URL Rewrite rules causes issues with trailing slashes and the pagination links

For example, if you visit a multisite blog with a URL like this: http://mydomain.com/bloga (without trailing slash) the 'Older Entries' link becomes http://mydomain.com/bloga/bloga/page/2/ -- it doubles up the blog slug in the URL causing a 404 error. Additionally any previous page link 1 2 3 4 5 etc have bad URL's as well.

If you visit http://mydomain.com/bloga/ (with trailing slash) the 'Older Entries' link is correctly http://mydomain.com/bloga/page/2/

I have found the issue to be present across multiple servers, with fresh, theme-less and plugin-less installations of WordPress

Change History (4)

comment:1 follow-up: @ocean903 years ago

With fresh installations of WordPress

WordPress 3.4 too?

comment:2 in reply to: ↑ 1 @sjlevy3 years ago

Replying to ocean90:

With fresh installations of WordPress

WordPress 3.4 too?

Oops forgot to mention, yes the problem persists after latest WP update

comment:3 @SergeyBiryukov3 years ago

  • Component changed from General to Multisite
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 @SergeyBiryukov3 years ago

While the double blog name issue in pagination links is still a duplicate of #18034, the fact that redirect_canonical() is disabled for IIS makes it more prominent. Related: #20484

On Apache, mydomain.com/bloga is redirected to mydomain.com/bloga/.

Last edited 3 years ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.