WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 5 years ago

Last modified 5 years ago

#21034 closed enhancement (invalid)

Flyout Menu on Backend doesn't Load Until Whole Page is Loaded

Reported by: prionkor Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Administration Keywords: needs-patch
Focuses: ui Cc:

Description

I have noticed this ever since the flyout menu was introduced. Menu items on flyout menus is not shows until the whole page gets loaded. For high speed connection its not a problem but it gets annoying people who connected in dial up (last week my ISP was down so i had to work with dial up for couple of days).

So, we could make the flyout menu items css/js to load on header so it doesn't wait for to load the whole page and make the backend accessible to and less annoying to low speed users.. For testing it you have to log into backend with low speed connection. If you need proof i can make a video with my dial up. Just let me know.

BTW: What i see on firebug that the css for flyout menu loads on header so i don't really find out what causes the menu to not showing on hover until the page loads.

Change History (9)

#1 @prionkor
9 years ago

  • Type changed from defect (bug) to enhancement

#2 @SergeyBiryukov
9 years ago

  • Component changed from General to Administration

#3 @georgestephanis
9 years ago

  • Cc George@… added

#4 @tillkruess
9 years ago

  • Cc me@… added

#5 @chriscct7
6 years ago

  • Focuses ui added
  • Keywords needs-patch added

#6 in reply to: ↑ description @arvindsinghu
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Replying to prionkor:

i Have work on my website to see your case and i found your problem use less because

in my website i found that the flyout menu load's the first ,

just try to clean all your browser caches :)

#7 @netweb
5 years ago

  • Milestone Awaiting Review deleted

#8 @SergeyBiryukov
5 years ago

I've just tested the admin with GPRS throttling in Chrome Dev Tools, and the issue is still valid, exactly as described.

If someone manages to find a solution, feel free to reopen with a patch.

#9 @SergeyBiryukov
5 years ago

  • Summary changed from Flyout Menu on Backend doesn't Loades Untill Whole Page is Loaded to Flyout Menu on Backend doesn't Load Until Whole Page is Loaded
Note: See TracTickets for help on using tickets.