WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#21048 closed enhancement (duplicate)

Add all toolbar button in tinymce editor Full Screen mode

Reported by: sabarinatht Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

Add all toolbar button in tinymce editor Full Screen mode for Visual mode. This will help users to perform more operation and functionalities in full screen mode without switching to normal mode for their style and other changes.

It will be helpful if you can add toolbar buttons in HTML mode too.

Attachments (2)

expanded.png (31.7 KB) - added by azaozz 8 years ago.
screenshots-edit-windows.png (100.6 KB) - added by Converting2wp 8 years ago.
Screenshots: normal editor, full screen editor

Download all attachments as: .zip

Change History (10)

#1 @sabarinatht
8 years ago

  • Component changed from General to Editor

#2 follow-up: @azaozz
8 years ago

  • Keywords close added

You mean to add all the buttons to distraction free mode? Folding the admin menu and moving the postboxes under the editor would give you pretty much a full-screen mode for the "normal" editor.

#3 in reply to: ↑ 2 ; follow-up: @sabarinatht
8 years ago

Replying to azaozz:

You mean to add all the buttons to distraction free mode? Folding the admin menu and moving the postboxes under the editor would give you pretty much a full-screen mode for the "normal" editor.

@azaozz : Not like that. Most of our clients need all the toolbar buttons in the full-screen mode so that they could handle content changes more easily since it provide a much larger view. Moving all the post meta boxes will give you a pretty look of full-screen mode but not really a good big surface for editing or full screen mode. My idea is to make WordPress more easy to use and friendly to users. By providing the full screen toolbar buttons allows the users to make the changes faster and easier rather than switching to normal for changes.

#4 @sabarinatht
8 years ago

  • Keywords close removed

@azaozz
8 years ago

#5 in reply to: ↑ 3 ; follow-up: @azaozz
8 years ago

Replying to sabarinatht:

...Most of our clients need all the toolbar buttons in the full-screen mode so that they could handle content changes more easily since it provide a much larger view.

Is that not acceptable (see screenshot)?

Moving all the post meta boxes...

Sorry, I meant switch to one column from Screen Options, not move the postboxes.

#6 in reply to: ↑ 5 @sabarinatht
8 years ago

Replying to azaozz:

Replying to sabarinatht:

...Most of our clients need all the toolbar buttons in the full-screen mode so that they could handle content changes more easily since it provide a much larger view.

Is that not acceptable (see screenshot)?

Moving all the post meta boxes...

Sorry, I meant switch to one column from Screen Options, not move the postboxes.

This is good. But it will be better and a good addition if you can provide all toolbar buttons in the full screen mode too. This will make WordPress much more friendly.

@Converting2wp
8 years ago

Screenshots: normal editor, full screen editor

#7 @Converting2wp
8 years ago

There are workarounds for 3.4.1 in #21197 (click Alt-Shift-G to get to the full screen editor with buttons) and #20237 (micro-plugin to add a new button that links to the "classic" full screen editor).

No, I don't think rejiggering the layout in Screen Options is enough -- at least when my work is primarily as an editor, not an author. Here's a screen shot of the

  • enlarged edit window surrounded by other areas that I access often
  • full screen edit window with edit buttons that I can use when I'm concentrating on text.

(Screen size: 15.5" -- using "classic" full screen gives me a view of 28 lines of text instead of 19.)

Yes, the DFW option to get to HTML in full screen mode is great, and if I could have the edit buttons it the DFW visual view, it would be lovely. But in the meantime, it's good to have an option for full screen with editing buttons.

#8 @azaozz
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Lets close this as duplicate of #20237 as there is some example code and better explanation of what's not working right.

Note: See TracTickets for help on using tickets.