WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#21056 closed defect (bug) (invalid)

Child Theme Upload Message: Are you sure you want to do this? Please try again.

Reported by: emiluzelac Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Themes Keywords:
Focuses: Cc:

Description

Hi,

I am not quite sure if this is somehow connected with http://core.trac.wordpress.org/ticket/20914 but at least you can read some of the previous messages. Anyways, 3.4 standard install when uploading a Child Theme, as soon as the file is uploaded there comes this message:

Are you sure you want to do this?
Please try again.

In this case I am not even able to see the "Activate" page or anything else for this matter, once again as soon as Theme is uploaded the message just comes up.

Thanks,
Emil

Attachments (2)

Screen Shot 2012-06-16 at 12.42.34 AM.png (5.9 KB) - added by emiluzelac 3 years ago.
childeleven.zip (430 bytes) - added by nacin 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 @nacin3 years ago

This works fine for me with the attached child theme.

Seems like the issue is that you are not on a 3.4 standard install — something is corrupted somewhere. If that is not the case, then we will need to figure out what nonce is failing. To do that, you can go into check_admin_referer() in wp-includes/pluggable.php, and then right before the wp_nonce_ays() call, do a var_dump( $action, $query_arg, $referer );.

@nacin3 years ago

comment:2 @emiluzelac3 years ago

Tried on a clean install, different server and everything went ok, if is not too much to ask to kind of keep an eye on this anyways.

Thanks,
Emil

comment:3 @nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

if is not too much to ask to kind of keep an eye on this anyways.

Yep. Haven't seen any other reports, but will look out for them.

comment:4 @emiluzelac3 years ago

Sounds good! Thank you

Note: See TracTickets for help on using tickets.