WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#21069 closed defect (bug) (invalid)

In situation when no posts in category Wp calls 404 template instead of category.php

Reported by: lyncis Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: General Keywords:
Focuses: Cc:

Description

When no posts in category I expect to see a part of template category.php calling between words:

<?php else: ?> ... <?php endif; ?>

But instead of this I see template 404.php

Change History (4)

comment:1 SergeyBiryukov22 months ago

Could not reproduce.

Just tested with Twenty Eleven. Visited an empty category archive, got the text from category.php:
http://core.trac.wordpress.org/browser/tags/3.4/wp-content/themes/twentyeleven/category.php#L46

comment:2 lyncis22 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Oops. Sorry, this bug appears only with plugin "No Category Parents", I guess it's plugin bug.

comment:3 SergeyBiryukov22 months ago

  • Milestone Awaiting Review deleted

comment:4 ocean9022 months ago

Could be related to #21020.

Note: See TracTickets for help on using tickets.