WordPress.org

Make WordPress Core

#21088 closed defect (bug) (fixed)

Fields to change Published dates not appearing properly in Internet Explorer 8 on WP 3.4

Reported by: aimutch Owned by: nacin
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.3
Component: UI Keywords: has-patch commit
Focuses: Cc:

Description

The date fields that appear when you select "Edit" to change the Published date are not displaying properly in Internet Explorer 8. To replicate the problem:

  1. Open a post or page on a WordPress 3.4 site with Internet Explorer 8
  2. Select "Edit" next to the Published date in the "Publish" box.
  3. The fields display for a second and then disappear. Sometimes when you hover over the hidden fields, they'll appear for a second.

Attached screenshot displays the bug.

I have repeated this multiple times on different PCs with Internet Explorer 8 on Windows XP/SP3.

Attachments (5)

WP3.4-Missing-Fields-Edit-Publish-Date.png (29.1 KB) - added by aimutch 22 months ago.
21088.published-date-ie8.png (16.4 KB) - added by SergeyBiryukov 22 months ago.
21088.patch (340 bytes) - added by SergeyBiryukov 20 months ago.
21088.2.patch (357 bytes) - added by lessbloat 18 months ago.
21088.3.patch (749 bytes) - added by lessbloat 18 months ago.

Download all attachments as: .zip

Change History (16)

comment:1 SergeyBiryukov22 months ago

  • Keywords reporter-feedback added

Could not reproduce. Looks fine on my test install: 21088.published-date-ie8.png.

Make sure you have disabled all plugins.

comment:2 azaozz22 months ago

Could not reproduce either. Sometimes IE does this when there is invalid css on the page. Perhaps check if any css is added by plugins and if yes, try disabling them and test again.

comment:3 cdomurad20 months ago

I am able to reproduce the error. The cuplrit seems to be the input/select/radio/checkbox elements not having their position set.

In order to view this bug in IE8 hit F12 and make sure your Browser Mode is IE8 Compat View and your Document Mode is IE7 Standards. Both are default options for IE8.

A "workaround" until this is fixed is by manually setting the position's to relative.

input[type='radio'],input[type='checkbox'],#timestampdiv select,#timestampdiv input{position:relative;}.

Hopefully this worked for you.

SergeyBiryukov20 months ago

comment:4 SergeyBiryukov20 months ago

  • Component changed from General to UI
  • Keywords has-patch added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 3.5
  • Version changed from 3.4 to 3.3

Reproduced with the settings from comment:3.

Same in 3.3, looks fine in 3.2. Probably a result of the CSS merge.

comment:5 azaozz20 months ago

The admin has always been running in IE8 "standards" mode. If it's forced in "compat" mode there would probably be other inconsistencies. Think there was a way to tell IE8 to always run in "standards" mode, better to do that.

lessbloat18 months ago

comment:6 lessbloat18 months ago

The "OK" buttons were also disappearing. Fixed in 21088.2.patch.

comment:7 nacin18 months ago

The patch is applied to ie.css, which is IE7. Is this also a bug in IE7? Is IE8 a problem? What to do here?

lessbloat18 months ago

comment:8 lessbloat18 months ago

Replying to nacin:

Is this also a bug in IE7?

Yes

Is IE8 a problem?

Yes, in "compat" mode.

What to do here?

How about 21088.3.patch?

comment:9 nacin18 months ago

  • Keywords commit added

Can someone confirm this is good in IE7 and IE8?

comment:10 ocean9018 months ago

IE8 Compat View and IE7 Document Mode is not a valid config for me. With default values it works in IE 8.

21088.3.patch with just the change in ie.css fixes the issue in IE 7.

comment:11 nacin18 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 22447:

Fix display of a post's date fields in IE7 and IE7 compat mode. props SergeyBiryukov, lessbloat. fixes #21088.

Note: See TracTickets for help on using tickets.