WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#21157 closed defect (bug) (fixed)

disapearing class=anything when ctrl+c & ctrl+v in tinymce editor

Reported by: thomask Owned by:
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.4
Component: TinyMCE Keywords:
Focuses: Cc:

Description

type

Lorem class=anything Ipsum

anywhere. Copy the text and paste it to the WP's WYSIWYG editor. The result is just

Lorem Ipsum

I have tried it with tinymce demo on their site and it works normaly, so it seems that only wp editor is affected.

The same wrong result is with class="anything", when using spaces around equal symbol (class = anything), it works normaly. Seems like some poorly written attemp to remove classes from pasted text (it does not affect id or other tag parameters i have tested)

P.S.: i am using Chrome if it makes some diference

Change History (4)

#1 @azaozz
8 years ago

  • Cc spocke added

#2 @azaozz
8 years ago

  • Milestone changed from Awaiting Review to Future Release

Confirmed that when pasting Lorem class=anything Ipsum and Lorem class="anything" Ipsum the class=... bit is removed. Works properly if these strings are in the content or were added in the Text editor. Seems like a bug in TinyMCE's 'paste' plugin that ideally will be fixed upstream (patches welcome).

#3 @iseulde
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I can reproduce this in WP 3.8, but not in 3.9. Looks like TinyMCE 4.0 fixed this.

#4 @SergeyBiryukov
6 years ago

  • Milestone changed from Future Release to 3.9
  • Resolution changed from invalid to fixed
Note: See TracTickets for help on using tickets.