WordPress.org

Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #21170, comment 133


Ignore:
Timestamp:
07/22/2017 01:02:07 PM (2 years ago)
Author:
azaozz
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #21170, comment 133

    initial v1  
    1212> I'm in favor of requiring that core JS filters always have a namespace or function name, but not so sure about making these mandatory for plugins.  I think it would add a significant amount of friction for a fairly minor use case.
    1313
    14 Then we will have many hook that are removable and some that are not? Don't think "partial support for removing actions and filters" is a good thing. Having said that, there may be a need for non-removable hooks, both for core and plugins. However if we are going to implement that I'd prefer to see it as another arg rather than as optional namespace, mostly for clarity/readability.
     14Then we will have many hook that are removable and some that are not? Don't think "partial support for removing actions and filters" is a good thing. Having said that, there may be a need for non-removable hooks, both for core and plugins. However if we are going to implement that I'd rather see it as another arg instead of an optional "namespace", mostly for clarity/readability.
    1515
    1616> Either way, PHP parity is not something we should necessarily strive for...