WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#21189 closed enhancement (duplicate)

We should improve the nonce failure page

Reported by: dd32 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Currently when a admin nonce expires, in most cases we catch this condition using check_admin_referer() which presents expired nonces with a rather ugly uninformative error message:
http://f.cl.ly/items/26271g453h2y0K393Y1l/Screen%20Shot%202012-07-06%20at%2012.14.25%20PM.png

I'd like to propose that we make this page a bit nicer to end users - who although are unlikely to hit it (I hope) it'd be nice to let them know what's actually happened.

My initial approach would be to change the page to

  • Include a WordPress logo, and a link back to the Admin area
  • Change the message to something like "The link you've followed has now expired, In order to complete the action you were performing, please return to the previous page, refresh it, and attempt to follow the link again.".
  • In the case where this is happening within the WordPress admin, it would make sense to have some kind of UI on the page as well - This can currently be done by not using check_admin_referer() and using wp_verify_nonce() directly and redirecting to an error page.

The current message could often cause confusion, as of course the user wants to do it (They just followed a link!) but as there's no continue button, they're left confused.

Change History (3)

#1 @SergeyBiryukov
8 years ago

Related/duplicate: #15394

#2 @c3mdigital
7 years ago

  • Keywords ux-feedback removed
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #15394

#3 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.