WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 8 months ago

#21190 closed enhancement (duplicate)

Add a action in check_admin_referer() in the event the nonce auth fails

Reported by: dd32 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: 2nd-opinion
Focuses: Cc:

Description

Currently plugins don't have a way to perform custom handling in the event that a nonce fails in check_admin_referer() - Whilst in most cases this will never be needed, I'd like the ability for plugins to be able to use check_admin_referer() directly AND have the option of redirecting failed nonces to their own page.

We currently have an action which is fired when a nonce passes:

do_action('check_admin_referer', $action, $result);

Change History (1)

comment:1 dd328 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24030.

Note: See TracTickets for help on using tickets.