WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#21218 closed defect (bug) (invalid)

plugin_dir_url and plugins_url display absolute filepath within url

Reported by: ChrisWiegman Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.1
Component: General Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

When using plugin_dir_url( __FILE__ ) or plugins_url( __FILE__ ) in a plugin with PHP 5.2.17 the absolute filepath is included in the URL string. In both cases the functions include the absolute filepath before the plugin directory name and after http://host/wp-content/plugins.

for example in PHP 5.2
http://mydomain.com/wp-content/plugins/my-plugin
would become
http://mydomain.com/wp-content/plugins/home/fileowner/public_html/wp-content/plugins/my-plugin/

in PHP 5.3 plugin_dir_url works as it should but plugins_url still displays the absolute URL within.

All has been tested using PHP 5.2.17 and PHP 5.3.13 in MAMP Pro on OSX 10.7

Change History (5)

comment:1 nacin21 months ago

Can't reproduce.

For your install, what are the values of WP_PLUGIN_DIR, ABSPATH, WP_CONTENT_DIR, __FILE__?

comment:2 ChrisWiegman21 months ago

Here is what I've got from the point at which I'm trying to call the function:

WP_PLUGIN_DIR /Users/xxx/Dropbox/MAMP/Local Sites/wordpress/public_html/content/plugins
ABSPATH /Users/xxx/Dropbox/MAMP/Local Sites/wordpress/public_html/
WP_CONTENT_DIR /Users/xxx/Dropbox/MAMP/Local Sites/wordpress/public_html/content
__FILE__ /Users/xxx/Dropbox/MAMP/Local Sites/wordpress/public_html/content/plugins/better-wp-security/better-wp-security.php
Last edited 21 months ago by nacin (previous) (diff)

comment:3 nacin21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

plugins_url() takes two arguments: $path and $plugin. $plugin should be __FILE__. $path should be what path within the plugin's directory you want to generate a URL to.

comment:4 ChrisWiegman21 months ago

Thanks. I was afraid it was something I was doing....

comment:5 SergeyBiryukov21 months ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.