Make WordPress Core

Opened 3 years ago

Closed 8 weeks ago

Last modified 8 weeks ago

#21284 closed feature request (duplicate)

Better New Plugin Filtering

Reported by: cbesett Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:


Currently trying to sort through available plugins by searching is quite laborious since there is no way to filter out things you don't want - such as plugins that haven't been tested with your version, haven't been updated in 100+ days, have a really low rating, etc. I'm constantly surprised at how many plugins i have to go through before i can even find one that is compatible with at least WP two versions ago much less the current one.

You should be able to filter on: Tested with current version, Rating of X+, Download at least XX, and so on to make it easier to find something you want.

And then column sorting after then by date added, date updated, rating, etc.

Change History (9)

#1 @SergeyBiryukov
3 years ago

Related: #18821, #19520

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

#2 @scribu
3 years ago

  • Milestone changed from Awaiting Review to WordPress.org

An even better approach would be if the search results were ordered automatically by all these criteria.

Anyway, this seems like a .org thing.

#3 @cbesett
3 years ago

The real need is the Add Plugin area of the wordpress installation though. I agree better sorting at the beginning would be recommended.

#4 @alexvorn2
3 years ago

just search in google for the best plugin and the work is done, why to make it more complicated?

#5 @cbesett
3 years ago

Because Google is not really good at determining how up to date something is.

#6 @nacin
22 months ago

  • Component changed from Plugins to Upgrade/Install

#7 @swissspidy
3 months ago

  • Keywords close added

The search results don't include very old plugins and uses different measures to have relevant search results.

In order to have filters like this, the plugin search API on WordPress.org would need to be improved. For this I recommend creating a ticket on https://meta.trac.wordpress.org. But I don't think this is really going to happen.

#8 @chriscct7
8 weeks ago

  • Keywords close removed
  • Milestone WordPress.org deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Agreed with comment:8, as well as noting the overall lack of interest over the last 3 years, closing as maybelater.

#9 @DrewAPicture
8 weeks ago

  • Resolution changed from maybelater to duplicate

Duplicate of #31192.

Note: See TracTickets for help on using tickets.