WordPress.org

Make WordPress Core

#21289 closed defect (bug) (duplicate)

Accessibility of Admin Custom Menu Builder (Appearance -> Menus)

Reported by: grahamarmfield Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.1
Component: Accessibility Keywords:
Focuses: Cc:

Description

The menu builder is really useful and powerful functionality. Unfortunately it appears to be only fully usable if users can use a mouse due to the drag and drop nature of some of the functionality. There are a number of other accessibility issues that make using the functionality of the screen difficult.

The highest priority issue is that of how keyboard only users can influence the hierarchy of the menu items and move them up and down in the list once they have been added. Perhaps some 'accessibility options' that work in the same way as those provided for Widgets could be included - along with some clear instructions on how to use them.

Other issues include:

  • Help and Screen Options links are present and can receive focus, when these links are actioned they appear to do nothing.
  • When tabbing between the menu items in the right hand side of the screen the items do not expose enough useful information for screen reader users to know which one has focus. There is also no visual clue as to location of focus for sighted keyboard-only users.

Change History (6)

comment:1 in reply to: ↑ description ; follow-up: nacin22 months ago

Replying to grahamarmfield:

Help and Screen Options links are present and can receive focus, when these links are actioned they appear to do nothing.

I think this is a general issue throughout the admin, not just on this screen. Sounds like a good case for a new ticket. Of note, however, I was able to open Help and Screen Options using only the keyboard, on this screen and others.

comment:2 in reply to: ↑ 1 grahamarmfield22 months ago

Replying to nacin:

Replying to grahamarmfield:

Help and Screen Options links are present and can receive focus, when these links are actioned they appear to do nothing.

I think this is a general issue throughout the admin, not just on this screen. Sounds like a good case for a new ticket. Of note, however, I was able to open Help and Screen Options using only the keyboard, on this screen and others.

Yes, odd that. Was using Firefox and those two links would not function but restarted the browser and they work fine now. So please scrub that part of my comments. My only comment on the screen options and help is one of discoverability of the content for screen reader users once the panel is open - since you have to tab back into the options. But that is not relevant for the issues on the Menu Builder screen. May raise a separate trac ticket on that.

comment:3 badeyes21 months ago

Hi Graham

As a screen reader user I agree with you, I find I have to delete links back to the point where I want to insert a new one if I make a mistake or want to change the order of the menu, would be nice if I were able to change the order by using an arrow system for moving them up and down.

cheers

Geof

comment:4 grahamarmfield21 months ago

This issue was actually raised some time ago - in #14045

Apologies for repeating, but of course it is a fundamental problem that still needs fixing.

comment:5 grahamarmfield17 months ago

Hopefully will get some attention in 3.6

comment:6 SergeyBiryukov17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14045.

Note: See TracTickets for help on using tickets.