WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#21296 closed enhancement (duplicate)

Media Library: Search all post types when attaching detached files

Reported by: abaumg Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

When attaching detached files in the Media Library, one is provided a search box.

Sometimes one might want to search all post types, especially when there are a lot of custom post types.

My patch adds an option named "All" which does exactly the above.

Attachments (3)

before.png (10.9 KB) - added by abaumg 7 years ago.
Search box, before
after.png (10.9 KB) - added by abaumg 7 years ago.
Search box, after
21296.patch (2.3 KB) - added by abaumg 7 years ago.

Download all attachments as: .zip

Change History (6)

@abaumg
7 years ago

Search box, before

@abaumg
7 years ago

Search box, after

@abaumg
7 years ago

#1 @abaumg
7 years ago

Before:

Search box, before

After:

Search box, after

#2 @markoheijnen
7 years ago

BTW the patch is incorrect since will be more then that. Any should load all the post types with show_ui == true. Related to that one: #20164

#3 @ocean90
7 years ago

  • Keywords has-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 3.4.1 deleted

Duplicate of #20164.

Note: See TracTickets for help on using tickets.