WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 21 months ago

Last modified 21 months ago

#21311 closed defect (bug) (wontfix)

The "Paste as plain text" feature in TinyMCE produces double-line breaks between paragraphs.

Reported by: uxtremist Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.4.1
Component: Editor Keywords:
Focuses: Cc:

Description

Mac OSX Lion, Chrome, WordPress 3.4.1

See attached SWF for a screen-video demonstration.

  • In WP-Admin -> Posts -> Add new, with the editor in visual mode, click the "Pase as plain text" icon

  • Paste your content into the window that pops up and click "Insert"

  • Note that two paragraphs seem to be double-line breaked.

  • Switch to HTML mode and note that there are extra " " spaces inserted between paragraphs.


Change History (5)

comment:1 @uxtremist3 years ago

The file was too big to attach (2mb) so here's the link:

http://www.uxtremist.com/wp-content/uploads/2010/06/2012-07-19_1124.swf

comment:2 @azaozz3 years ago

  • Keywords close added

Yes, the "Paste as text" popup converts each line to a paragraph, so if there are more than one line break it would make empty paragraphs. It's been working like that for quite some time.

When pasting plain text, best is to use the "Text" editor tab (formerly HTML). Thinking we could remove the "Paste as text" button as it duplicates the functionality of the Text tab.

comment:3 follow-up: @uxtremist3 years ago

Thanks for the response. I can't see the "Text" editor tab at all, even in full-screen mode. Is this in version 3.4.1?

Note: In the TinyMCE demonstration, the paste-as-plain-text plugin doesn't have a pop-up window — but it otherwise behaves as I would expect; that is, it doesn't insert empty   lines: http://www.tinymce.com/tryit/full.php

I agree that if the "Paste as text" button is redundant, it should be removed. What happens if I want to paste HTML into the "Text" editor tab? Does it strip out the HTML tags?

comment:4 in reply to: ↑ 3 @c3mdigital21 months ago

  • Keywords close removed
  • Resolution set to wontfix
  • Status changed from new to closed

Replying to uxtremist:

Thanks for the response. I can't see the "Text" editor tab at all, even in full-screen mode. Is this in version 3.4.1?

Note: In the TinyMCE demonstration, the paste-as-plain-text plugin doesn't have a pop-up window — but it otherwise behaves as I would expect; that is, it doesn't insert empty   lines: http://www.tinymce.com/tryit/full.php

I agree that if the "Paste as text" button is redundant, it should be removed. What happens if I want to paste HTML into the "Text" editor tab? Does it strip out the HTML tags?

The text tab does was formally named the HTML tab and no it does not strip out HTML except iframe and script tags if the user does not have unfiltered HTML caps. I'm closing as wont fix since the the double line breaks are the intended behavior.

comment:5 @SergeyBiryukov21 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.