WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#21315 closed defect (bug) (duplicate)

Menu Position Causing Custom Post Type to Not Show in WordPress Admin

Reported by: smub Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 3.4.1
Component: Posts, Post Types Keywords: needs-patch
Focuses: Cc:

Description

Hey Guys,

So today I was trying to add yet another Custom Post Type to the site. So far aside from the default post types, I have 5 additional CPTs. I tried adding this 6th one, and the item would not show in the admin menu.

Important to note, that it was registered. Because in the admin bar, under the "New" drop-down I could see my new post type.

It baffled me for a bit. All of my other post types have menu_position 20. This one was also 20. I changed the menu position to 25, and it made no difference.

However, if I change it to 30, it shows up just fine. If I make it 19, then it shows up just fine.

Is there a limit or something specified for how many items can be at one position? I was thinking that it would just keep on adding under the other post types.

Now this specific post type is added under Comments and Gravity Forms menu... Sort of making it out of place. It should be with other post types that I have in the site.

Change History (4)

comment:1 ryan21 months ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed
Last edited 21 months ago by ryan (previous) (diff)

comment:2 ryan21 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 scribu21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

There is a fixed number of slots available, due to the way the menu items are stored. This should no longer be a problem once #12718 lands.

Closing as duplicate.

comment:4 nacin21 months ago

Better as a duplicate of #16946, #15595, and others.

Note: See TracTickets for help on using tickets.