WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 3 years ago

#21316 closed defect (bug)

wp_check_php_mysql_versions() is broken in PHP 4 — at Initial Version

Reported by: SergeyBiryukov Owned by:
Milestone: 3.4.2 Priority: normal
Severity: normal Version: 3.4
Component: Upgrade/Install Keywords: has-patch commit
Focuses: Cc:

Description

Since [19760].

wp_load_translations_early() includes functions.php, which in turn includes option.php. This leads to the error message when running PHP 4:

Parse error: syntax error, unexpected T_VARIABLE in wp-includes/option.php on line 225

In 3.3, a proper error message was shown:

Your server is running PHP version 4.4.7 but WordPress 3.3.3 requires at least 5.2.4.

Change History (1)

@SergeyBiryukov3 years ago

Note: See TracTickets for help on using tickets.