WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#21370 closed defect (bug) (duplicate)

comment_reply_link() causes identical content to be served from two URLs

Reported by: devgav Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Comments Keywords: has-patch
Focuses: Cc:

Description

comment_reply_link() returns an anchor to the current post permalink with the following appended '?replytocom=1#respond'.

This is causing two results for the same page to appear in common search engines.

http://www.example.com/blog/blog-title
&
http://www.example.com/blog/blog-title?replytocom=1#respond

comment_reply_link() already adds 'nofollow' to the login link if the user is logged out. The attached patch adds nofollow to the comment reply link also.

Attachments (1)

comment-template.php.patch (1.1 KB) - added by devgav 9 years ago.
Solves #21370

Download all attachments as: .zip

Change History (3)

#1 @SergeyBiryukov
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This was an intentional change in [16230]. Also related: [17891].

Previous discussions: #10550, #16709, #16881, #16893, #18547

Going to close as a duplicate of #18547.

#2 @sirzooro
9 years ago

  • Cc sirzooro added
Note: See TracTickets for help on using tickets.