WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#21387 closed feature request (duplicate)

Add a CodeURI field to plugin file header

Reported by: niallkennedy Owned by:
Milestone: Priority: normal
Severity: trivial Version:
Component: WordPress.org Site Keywords:
Focuses: Cc:

Description

I would like to make it easier for developers not associated with a plugin to contribute modified versions.

The plugins SVN has grown to a size where it's no longer possible for a member of the WordPress community to create a new ticket and select a plugin from "component" to patch and improve software. Some plugins manage code on a site such as GitHub and commit a release into the plugins SVN.

I might use WP Super Cache in my WordPress installation, one of 3.5 million installs using the plugin. I modify the plugin and would like to share my changes.

  1. Try creating a new ticket in Plugins Trac. The plugin is not listed as an available component.
  2. Find the Plugin URI. If not WordPress.org look around on the author's site for links to another repo.
  3. Search GitHub for the developer(s) and/or project
  4. Email the developer(s) if they have a contact email listed

Give up?

File header currently includes a Plugin URI which commonly points to the WP.org plugin page for the plugin or sometimes to a webpage on the developer's site. I could overload "Donate" to encourage code donations instead of monetary donations but that could be confusing.

I'd like to provide a explicit code URI field to encourage outside contributions of modifications in the GPL spirit.

Change History (3)

#1 @SergeyBiryukov
9 years ago

  • Milestone changed from Awaiting Review to WordPress.org

#2 @bpetty
8 years ago

  • Milestone WordPress.org deleted
  • Resolution set to invalid
  • Status changed from new to closed

Duplicate of #meta160.

#3 @bpetty
8 years ago

  • Resolution changed from invalid to duplicate
Note: See TracTickets for help on using tickets.