WordPress.org

Make WordPress Core

#21393 closed defect (bug) (fixed)

Fix taxonomy term description comment, help and translation

Reported by: F J Kaiser Owned by: F J Kaiser
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.4.1
Component: Help/About Keywords: has-patch
Focuses: Cc:

Description

The string The description is not prominent by default, however some themes may show it. appears inside the help, on the left hand of the WP_List_Table on edit-tags.php (when adding a new term) and on the term details screen on edit-tags.php?action=edit.

The problem is, that there's a typo (, vs. ;) on the screens, and a slightly different string (including a <strong> tag) inside the help tab.

Attachments (4)

21393_1.patch (1.9 KB) - added by F J Kaiser 21 months ago.
21393_2.patch (1.9 KB) - added by F J Kaiser 21 months ago.
21393.3.patch (1.0 KB) - added by SergeyBiryukov 21 months ago.
21393.4.patch (847 bytes) - added by SergeyBiryukov 19 months ago.

Download all attachments as: .zip

Change History (12)

F J Kaiser21 months ago

comment:1 F J Kaiser21 months ago

  • Keywords has-patch added; needs-patch removed
  • Owner set to F J Kaiser
  • Status changed from new to reviewing
  • Version set to 3.4.1

Patch is from trunk latest.

Splits the string inside the help tab (containing the <strong> tags inside the string) into two strings and moves the tags outside the translation function, as __('Description'); is already in use. Adds the ; to the overview screen.

comment:2 ocean9021 months ago

  • Milestone changed from Awaiting Review to 3.5

I think we can combine these strings.

edit-tags.php?taxonomy=category: The description is not prominent by default, however some themes may show it.

and

edit-tags.php?action=edit: The description is not prominent by default; however, some themes may show it.

See the use of , and ;.


Description shouldn't be extracted, it doesn't help really and is inconsistent to the other lines.

F J Kaiser21 months ago

comment:3 F J Kaiser21 months ago

Yea, I missed one ; out - the new patch fixes them all.

The reason behind splicing the string that had the <strong>-tag was reducing the amounts of strings that need to get translated.

SergeyBiryukov21 months ago

comment:4 SergeyBiryukov21 months ago

The strings in 21393_2.patch are still different.

I'd prefer not to combine the strings here:

  1. We should keep hyphen in the translatable part (in Russian, &#8212; (mdash) is used instead).
  2. This would make it __( '<strong>Description</strong> -' ), so trying to combine the strings would result in a new one.
  3. I've translated the string in edit-tags.php a bit differently, to avoid the tautology.

If anything, let's just fix the comma vs. semicolon for consistency.

Last edited 20 months ago by SergeyBiryukov (previous) (diff)

comment:5 nacin19 months ago

  • Keywords needs-patch added; has-patch removed

A semicolon, not a colon, is proper in "The description is not prominent by default; however some themes may display it." "However" is an adverb, rather than a conjunction.

It may be better to just eliminate the semicolon and make two sentences, or use a conjunction. "Some themes may display the description." seems sufficient.

SergeyBiryukov19 months ago

comment:6 SergeyBiryukov19 months ago

21393.4.patch adds a semicolon to the string in edit-tag-form.php.

comment:7 helenyhou18 months ago

  • Component changed from UI to Help/About
  • Keywords has-patch added; needs-patch removed

comment:8 ryan18 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In [22261]:

Enter the semicolon. Props F J Kaiser, SergeyBiryukov. fixes #21393

Note: See TracTickets for help on using tickets.