Make WordPress Core

Opened 3 years ago

Closed 3 months ago

#21411 closed defect (bug) (worksforme)

Current Local Time for Port-au-Prince, Haiti is incorrect.

Reported by: pnommensen Owned by: patrick@…
Milestone: Priority: normal
Severity: minor Version: 3.4.1
Component: Date/Time Keywords:
Focuses: Cc:


When the Port-au-Prince Timezone is selected via wp-admin/options-general.php the Local Time is one hour behind. Please see http://wwp.greenwichmeantime.com/time-zone/caribbean/haiti/time-haiti/ for the correct local time.

Yes, the problem occurs even when all plugins are deactivated and the default theme is activated.

Change History (5)

#1 @dd32
3 years ago

  • Component changed from General to Date/Time

Works for me, WordPress reports 21:15, the linked site reports 9:15pm

As for why it doesn't work for you, either:

  • The server time is incorrect, causing PHP to return the incorrect timestamp
  • The servers timezone file is incorrect or out of date, leading to it reporting a incorrect time offset (It should be reporting GMT-5hr or GMT-4hr when Daylight Savings has kicked in)

What does WordPress report the UTC time as? It should report the time shown here: http://wwp.greenwichmeantime.com/ If it doesn't, the problem is the first point above, if it reports it correct, but reports the Local time incorrect, it's the second point above

Last edited 3 years ago by dd32 (previous) (diff)

#2 @dd32
3 years ago

  • Keywords close added

Actually, it's most likely definitely the 2nd point above, The Daylight savings dates for Haiti changed in March 2012, chances are, the PHP version you're running has an out of date Timezone for Haiti.

Version 0, edited 3 years ago by dd32 (next)

#3 @pnommensen
3 years ago

Thanks for your response. I have php v. 5.2.17 from 06 January 2011 installed. (http://www.rfahaiti.org/phpinfo.php) The UTC time listed is 04:50 right now, same as http://wwp.greenwichmeantime.com/.

#4 @mbijon
2 years ago

Possibly related: #20328

Do the tests added in http://core.trac.wordpress.org/changeset/1233/tests reproduce this behavior?

#5 @chriscct7
3 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No additional reports in 2 years, unable to reproduce, and likely caused by 2 on comment:2 above. Closing as worksforme

Note: See TracTickets for help on using tickets.