WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 8 months ago

#21428 closed defect (bug) (worksforme)

Bad mail subject encoding on new blog notification

Reported by: TheSteelRat Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.1
Component: Multisite Keywords:
Focuses: Cc:

Description

Email subject is in Russian language. When trying to add new blog using page http://mysite.com/wp-admin/network/site-new.php, user gets email where subject is like - =??B??=. So I was trying to find where this bug appears. And I think, I found it.

Script tries to send notification using function wpmu_welcome_notification on line http://core.trac.wordpress.org/browser/tags/3.4.1/wp-includes/ms-functions.php#L1250. But get_option('blog_charset') returns empty string, so header is bad-generated and encoded...

Change History (2)

comment:1 SergeyBiryukov21 months ago

  • Keywords reporter-feedback added

Couldn't reproduce on a clean install. get_option('blog_charset') in line 1250 returns UTF-8.

  1. What's the charset value in Settings → Reading?
  2. Could you try with all plugins disabled?

comment:2 jeremyfelt8 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No reporter feedback after 12 months.

Note: See TracTickets for help on using tickets.