WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 8 years ago

Last modified 6 years ago

#2145 closed defect (bug) (worksforme)

RTE cannot do ordered lists

Reported by: Podz Owned by: andy
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Unchecking "WordPress should correct invalidly nested XHTML automatically" allows the [properly] nested ordered lists to survive the post process.

It would then seem that the WYSIWYG editor knows more about x/html than whatever process reviews the posts upon submission.

http://wordpress.org/support/topic/53022

Change History (5)

comment:1 @darkfate10 years ago

  • Milestone changed from 2.0 to 2.1

yea this is an annoying bug. hopfully andy can fix this for 2.1 (or 2.0.1 which is sure to come)

comment:2 @matt9 years ago

  • Milestone changed from 2.1 to 2.2

comment:3 @rob1n8 years ago

  • Component changed from Template to TinyMCE
  • Owner changed from anonymous to andy

comment:4 @foolswisdom8 years ago

  • Milestone changed from 2.2 to 2.4

comment:5 @Nazgul8 years ago

  • Milestone 2.4 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I am unable to reproduce this on the current trunk (r5624)

Maybe it's been fixed in the meantime?

Note: See TracTickets for help on using tickets.