WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 3 months ago

#21460 closed defect (bug) (worksforme)

The accesskeys in Quicktags don't work in all browsers

Reported by: azaozz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

IE (Alt+letter) works properly. Firefox (Alt+Shift+letter) only focuses the corresponding Quicktags button sometimes. Doesn't perform the action. If the button is hidden, performs the action (this shouldn't happen in Quicktags). Chrome doesn't seem to do anything. Opera works differently: Shift+Esc brings a list of all defined access keys on that page. The Quicktags access keys are not listed there.

Attachments (1)

21460.patch (759 bytes) - added by azaozz 21 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 azaozz21 months ago

Most of these problems on the Edit Post screen are caused by having two instances of Quicktags there, one for the Text editor and another in the Comments postbox (used for Add, Quick Edit, Reply). So there are more than one button with the same accesskey attribute.

In order to use access keys in Quicktags we will need to set them dynamically on the currently used instance only. To be able to do that Quicktags would need a concept of "focused" instance, similar to TinyMCE.

azaozz21 months ago

comment:2 azaozz21 months ago

In [21418]:

Quicktags: don't call the callback on pressing the access key when a button is not visible, see #21460

comment:3 azaozz21 months ago

[21418] also takes care of the bugs reported by @SergeyBiryukov on #17992 whitout the need to change TinyMCE shortcut keys in Firefox.

comment:4 azaozz3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Firefox seem to work well now: on pressing Alt+Shift+accesskey, it highlights the button, pressing the spacebar or Enter performs the action and returns focus (and the caret) to the textarea.

Note: See TracTickets for help on using tickets.