WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#21486 closed defect (bug) (fixed)

Twenty Twelve: Styling fixes needed for images, galleries, search button and some headings

Reported by: chellycat Owned by:
Milestone: 3.5 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:
PR Number:

Description

I found the following style issues with the theme:

Attachments (6)

21486-submit-button-top-padding-fix.diff (485 bytes) - added by chellycat 7 years ago.
Makes the top/bottom padding of the submit button even with the input field for search and password forms.
21486-fix-line-height-of-multiline-headers.diff (461 bytes) - added by chellycat 7 years ago.
Increases the line-height for multi-line headers just a tad b/c it was looking a bit tight before. I'm aware that the line-heights were calculated following a formula, but multi-line headers were a bit squished. I don't feel that this fix breaks the vertical rhythm too much, but feel free to adjust if needed.
remove-auto-width-on-images.diff (546 bytes) - added by chellycat 7 years ago.
Removing width: auto from images, which was causing images resized in the editor to appear full width. The "width: auto" is an IE8 specific fix and should be moved to IE8-specific styles.
21486-remove-auto-width-on-images.diff (546 bytes) - added by chellycat 7 years ago.
Please use this attachment instead of "remove-auto-width-on-images.diff", because it has the ticket number appended.
21486-entry-content-line-height-fix.diff (445 bytes) - added by chellycat 7 years ago.
Adds line-height to entry-content and entry-summary, so that elements appearing outside of paragraph tags inside these containers will still have the appropriate line-heights.
21486-pingback-line-height-fix.diff (394 bytes) - added by chellycat 7 years ago.
Adds line-height for pingbacks, which was looking too tight when pingbacks spanned multiple lines.

Download all attachments as: .zip

Change History (14)

#1 @chellycat
7 years ago

Galleries look fine to me on second look.

@chellycat
7 years ago

Makes the top/bottom padding of the submit button even with the input field for search and password forms.

@chellycat
7 years ago

Increases the line-height for multi-line headers just a tad b/c it was looking a bit tight before. I'm aware that the line-heights were calculated following a formula, but multi-line headers were a bit squished. I don't feel that this fix breaks the vertical rhythm too much, but feel free to adjust if needed.

#2 @jkudish
7 years ago

  • Keywords has-patch added

#3 follow-up: @lancewillett
7 years ago

  • Milestone changed from Awaiting Review to 3.5

The submit button is not the same height as the text field (in both the search widget and on the password protected post:

I think this is fixed now, can you re-check it?

@chellycat
7 years ago

Removing width: auto from images, which was causing images resized in the editor to appear full width. The "width: auto" is an IE8 specific fix and should be moved to IE8-specific styles.

@chellycat
7 years ago

Please use this attachment instead of "remove-auto-width-on-images.diff", because it has the ticket number appended.

#4 in reply to: ↑ 3 @chellycat
7 years ago

Replying to lancewillett:

The submit button is not the same height as the text field (in both the search widget and on the password protected post:

I think this is fixed now, can you re-check it?

Just ran svn up and checked it again, confirming that it's fixed. Galleries also look fine, so that can be removed from the list.

@chellycat
7 years ago

Adds line-height to entry-content and entry-summary, so that elements appearing outside of paragraph tags inside these containers will still have the appropriate line-heights.

@chellycat
7 years ago

Adds line-height for pingbacks, which was looking too tight when pingbacks spanned multiple lines.

#5 @chellycat
7 years ago

I have uploaded patches for all of the issues reported, except for galleries (they appear to work now, I think I was looking at outdated code for that one. The submit button issue has also already been fixed, as confirmed above).

#6 @lancewillett
7 years ago

Thanks for all the patches and notes, Michelle. Noted the IE8 fix suggestion over on #21440.

#7 @lancewillett
7 years ago

In [21462]:

Twenty Twelve: line-height style fixes, props chellycat. See #21486.

  • For entry titles match larger screen style with the base styles to add a bit more line-height.
  • Add line-height to entry-content and entry-summary, so that elements appearing outside of paragraph tags inside these containers will still have the appropriate line-heights.
  • Add line-height for pingbacks, which looks a bit too tight when pingbacks span multiple lines.

#8 @lancewillett
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.