WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#21499 closed defect (bug) (fixed)

Meta-boxes don't behave as normal on edit comment page

Reported by: bbrooks Owned by: nacin
Milestone: 3.5 Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: has-patch commit
Focuses: Cc:
PR Number:

Description

The following was noted on trunk rev.21,458

On the edit comment page, meta boxes added by plugins (like Akismet) are not collapsible or rearrange-able.

Also, unchecking meta boxes in the 'screen options' in this context does not hide them as expected

To reproduce:

  1. Add an arbitrary meta-box to the edit comments page (Fastest way is just to enable Akismet)
  2. Make a comment
  3. Go to the comment editor for that comment
  4. Below the main text area, try to close or move the meta-box you added in step 1

Best guess is that whatever JS is required for metabox behavior is not loaded on the edit comment page.

Attachments (3)

21499.patch (958 bytes) - added by SergeyBiryukov 7 years ago.
21499.2.patch (946 bytes) - added by SergeyBiryukov 7 years ago.
Refreshed after [21592]
21499.3.patch (1.2 KB) - added by SergeyBiryukov 7 years ago.

Download all attachments as: .zip

Change History (8)

#1 @SergeyBiryukov
7 years ago

  • Component changed from Comments to Administration
  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.5
  • Version changed from 3.4.1 to 2.7

@SergeyBiryukov
7 years ago

Refreshed after [21592]

#2 @helenyhou
7 years ago

  • Keywords commit added

And just like that, it works!

#3 follow-up: @nacin
7 years ago

Would setting 'postbox' to be a dependency for 'comment' make more sense? Looks like we do this for post, link, and dashboard, though not for nav-menu. Looking at wp-admin/nav-menus.php, looks like a lot of those lines should be removed in favor of dependencies.

#4 in reply to: ↑ 3 @SergeyBiryukov
7 years ago

Replying to nacin:

Would setting 'postbox' to be a dependency for 'comment' make more sense?

That works as well: 21499.3.patch.

Looking at wp-admin/nav-menus.php, looks like a lot of those lines should be removed in favor of dependencies.

Created #21777 for nav-menus.php.

#5 @nacin
7 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In [21697]:

Load the meta box sortables JS on the Edit Comment screen. props SergeyBiryukov. fixes #21499.

Note: See TracTickets for help on using tickets.