WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#2158 closed defect (bug) (duplicate)

TinyMCE load default lang file only

Reported by: Sewar Owned by:
Milestone: Priority: high
Severity: major Version: 2.0
Component: Administration Keywords: TinyMCE language translate
Focuses: Cc:

Description

(Sorry for my not-so-perfect english)

There are problem when translating TinyMCE because tiny_mce_gzip.php load default language files (en.js), you had better use [get_locale()] from wp-l10n.php to get local filename.

Change [this.defParam("language", "en");] in tiny_mce.js will not do anything and will confusing the translators.

Change History (4)

comment:1 @skeltoac9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

TinyMCE lang support is replaced with WP's gettext.

comment:2 @Sewar9 years ago

  • Milestone changed from 2.0 to 2.0.2
  • Resolution invalid deleted
  • Status changed from closed to reopened

Yes, you're right. I've do some test and it works right.

But the problem is TinyMCE strings isn't added to language file (POT), so the translators (like me) will face this problem and maybe create other tickets for this problem.

comment:3 @capt_kirk9 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

This ticket is duplicative with 2476.

I agree wholeheartedly with Sewar and acknowledge that he had the ticket much earlier than me. 2158 was closed when I wrote 2476 and, even though I did a search, I didn't see it. I would have appended the patch to this ticket, if I had seen it.

I'm marking as closed/duplicate, just because I've already posted a patch on 2476 and this is easier than moving the patch over here.

comment:4 @anonymous8 years ago

  • Milestone 2.0.2 deleted

Milestone 2.0.2 deleted

Note: See TracTickets for help on using tickets.