WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 19 months ago

#21592 closed defect (bug) (worksforme)

TinyMce Bug - delete image with keyboard

Reported by: asannad Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords: reporter-feedback
Focuses: Cc:

Description (last modified by SergeyBiryukov)

In post editor, when trying to delete an image using keyboard delete button it does not work. Pressing delete on image takes back to previous page. Happens in mac os/ chrome 21.

Steps to reproduce

  • Create or edit a post
  • Switch to the Visual Editor
  • Upload and insert an image into the post
  • Move focus away from the editor (i.e. click anywhere outside the editor)
  • Click on the inserted image
  • Press "Delete"
  • The image is not deleted and instead the user is navigated back to the previous page.

Change History (5)

comment:1 SergeyBiryukov2 years ago

  • Component changed from General to TinyMCE
  • Description modified (diff)

comment:2 batmoo2 years ago

  • Cc batmoo@… added

comment:3 mintindeed2 years ago

  • Cc gabriel.koen@… added

comment:4 azaozz23 months ago

  • Keywords reporter-feedback added

You mean the "Backspace" key or a real "Delete" key (above the arrow keys on a full size keyboard)?

Couldn't reproduce this with the backspace key, Chrome 21.0.1180.79, MacOS 10.7.4. Do the "Edit" and "Delete" buttons pop up when you click on the image?

comment:5 azaozz19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This sounds like a specific browser issue with contenteditable mode, i.e. the browser interprets the delete key as a shortcut to navigate to the previous page instead of a keystroke in the editable area. Perhaps it was fixed in never browser version?

No reporter feedback in 4 months, closing as worksforme. Feel free to reopen with more information.

Note: See TracTickets for help on using tickets.