WordPress.org

Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #21613, comment 3


Ignore:
Timestamp:
08/17/12 15:29:24 (5 years ago)
Author:
vhauri
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #21613, comment 3

    initial v1  
    77> Current behaviour appears to be proper. 
    88 
    9 Well, the code comment was recently updated to reflect the fact that the behavior is backwards( 'Whether the $content should not pass through htmlspecialchars().' has become 'Whether the $content should NOT pass through htmlspecialchars().'). I'm not sure the variable name $richedit makes sense anymore...perhaps $dont_encode = false would make more sense. Either way, having a variable that a) isn't really descriptive and b) written as a double negative is probably not ideal for clarity. 
     9Well, the code comment was recently updated to reflect the fact that the behavior is backwards( 'Whether the $content should pass through htmlspecialchars().' has become 'Whether the $content should NOT pass through htmlspecialchars().'). I'm not sure the variable name $richedit makes sense anymore...perhaps $dont_encode = false would make more sense. Either way, having a variable that a) isn't really descriptive and b) written as a double negative is probably not ideal for clarity.