WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 19 months ago

Last modified 19 months ago

#21614 closed defect (bug) (duplicate)

wp_mime_type_icon PHP notice fixes

Reported by: sc0ttkclark Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.4.1
Component: Warnings/Notices Keywords:
Focuses: Cc:

Description

wp_mime_type_icon ends up sending to the 'wp_mime_type_icon' filter: $icon, $mime, and $post_id

Based on the PHP, it's set in such a way that PHP notices could be generated for variables don't exist.

I've attached my patch that should resolve those potential notices.

Attachments (1)

21615.patch (580 bytes) - added by sc0ttkclark 20 months ago.

Download all attachments as: .zip

Change History (6)

sc0ttkclark20 months ago

comment:1 sc0ttkclark20 months ago

Oops, missed it by one number, pretend my patch was really 21614.patch :)

comment:2 SergeyBiryukov20 months ago

  • Component changed from Media to Warnings/Notices
  • Milestone changed from Awaiting Review to 3.5

comment:3 nacin19 months ago

  • Milestone 3.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21828.

comment:4 sc0ttkclark19 months ago

This ticket was duplicated by #21835 (partially), but committed as part of the patch that went in for it. (just noting here for reference)

comment:5 sc0ttkclark19 months ago

  • Keywords has-patch dev-feedback removed
Note: See TracTickets for help on using tickets.