Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#21735 closed enhancement (duplicate)

Clarify the potentially destructive nature of changing your site address from General Settings

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.1
Component: Administration Keywords:
Focuses: Cc:


On the General Settings screen we have two nice big fields for changing your WordPress Address and Site Address. If you don't know what you're doing then changing these values can kill your site.

We should do one or both of the following:

There could be a JavaScript AYS along the lines of "Are you sure you want to change your site address? Make sure you know what you're doing first, etc" or there could be a server-side AYS using wp_die() with a "Yes I know what I'm doing" confirmation button.


Change History (3)

#1 @SergeyBiryukov
3 years ago

Related/duplicate: #18769, #10970

#2 follow-up: @nacin
3 years ago

We are introducing a constant to handle multisite-in-a-subdirectory in #19796. I haven't done final reviews on that yet because I want to see how we can use a constant, probably the same one, here.

If home == siteurl, we should just hide the siteurl field. home should possibly stay but only to be able to change domains, add/remove www, etc. We should add some validation as discussed in #10970 and elsewhere. (See dd32's plugin.)

If home != siteurl, then we give them the UI. Unless it is constant-controlled (new way) in which case, no UI.

Beyond that, this is essentially a duplicate of #10970. Shall we close this and move that to 3.5?

#3 in reply to: ↑ 2 @johnbillion
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Replying to nacin:

Beyond that, this is essentially a duplicate of #10970. Shall we close this and move that to 3.5?


Note: See TracTickets for help on using tickets.