WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#2175 closed defect (bug) (worksforme)

mySQL 5, PHP5 : Cannot save a post

Reported by: Podz Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Administration Keywords:
Focuses: Cc:

Description

Possible bug report...

Just upgraded to MySQL 5, PHP5, and WP 2.0 on an IIS 6 box. So far so good, however, when I try and create a new entry in WP, I must click "post" before I can click "save". If I click "save", I get this:

WordPress database error: [Incorrect datetime value: for column 'post_date' at row 1]

Should I be able to save here? Should the save button maybe be disabled until the post has actually been submitted?

http://wordpress.org/support/topic/53655?replies=1

Attachments (1)

ignore.diff (1.1 KB) - added by ryan 10 years ago.
Now with IGNORE

Download all attachments as: .zip

Change History (10)

comment:2 @ryan10 years ago

MAybe use INSERT IGNORE and UPDATE IGNORE for posts since we really do want a zero date.

@ryan10 years ago

Now with IGNORE

comment:4 @ryan10 years ago

  • Milestone changed from 2.1 to 2.0.1

comment:5 @ryan10 years ago

I think we nailed this one, but we need confirmation. Resolving for now. Reopen if it's still a problem.

comment:6 @ryan10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 @JamesP10 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I tried numerous times to get this working on the new version and I have had absolutley no luck. The situation is the same, MySQL 5 on IIS 6 / Windows Server 2003 Standard. I also don't get an error message.

I was upgrading from an older version of the backend database (I think it was Wordpress version 1.2 or 1.5). I followed the instructions for upgrading and then some to no avail. I download the brand new Wordpress 2.0.1 version, and used the upgrade function from that; however, it still didn't work.

Not sure if this is the same issue, or an issue with the actual upgrade script.

comment:8 @foolswisdom9 years ago

  • Milestone 2.0.1 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Hi JamesP,

This ticket has not been updated in 7 months. Is there still an issue? How did you resolve the issue?

Marking WORKSFORME without testing for now, but please do update if there is more details to this story.

Thank you,
Lloyd

comment:9 @Viper007Bond9 years ago

Confirmed "works for me". Running both MySQL 5 and PHP 5 on my sit and local machine and WP 1.5.2, WP 2.0.4, and latest SVN all work for me just fine.

Note: See TracTickets for help on using tickets.