WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#21768 closed defect (bug) (duplicate)

Twenty Twelve: "glue" text in .entry-meta not marked up. No way to target it with CSS.

Reported by: markjaquith Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

The entry meta section of Twenty Twelve contains selectors around the clickable items, but not the "glue" text between them. For instance, I'm the only person who posts on my blog. I don't want " by Mark" at the bottom of each entry. But only the "Mark" part can be targeted by CSS. The "by" is just free-floating.

Ideally I'd be able to display: none; on a selector and kill the whole " by Mark" portion.

This might introduce i18n difficulties if we take it too far, but the author section seems like something that should be targetable, at least. More advanced cases can just define their own twentytwelve_entry_meta().

Change History (3)

#1 @nacin
6 years ago

Closely related, #21759. comment:1:ticket:21759 outlines the behavior in Twenty Eleven... its markup may be desirable here.

#2 @lancewillett
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21759 since this ticket also specifically addresses the "by author" markup. I vote not to wrap any of the other metadata, I'd consider it to be advanced usage.

#3 @SergeyBiryukov
6 years ago

  • Milestone 3.5 deleted
Note: See TracTickets for help on using tickets.