WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 weeks ago

Last modified 3 weeks ago

#21770 closed defect (bug) (invalid)

Multiple New Feature Pop-ups mess UI

Reported by: titanas Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Administration Keywords: dev-feedback
Focuses: ui Cc:

Description

WordPress admin and plugins http://dl.dropbox.com/u/184353/wordpress-admin-pop-ups.png New Feature Pop-up messages appear on the admin simultaneously, blocking each other messages and functionality. The UI gets seriously messed up.

User attention focuses on how to get rid the overlaping pop-ups rather than reading the messages and understand and start using the new features.

Change History (10)

comment:1 @ocean903 years ago

  • Keywords close added

Feature pointers are designed only for internal pointers yet. You should report this to the plugin author.

comment:2 @scribu3 years ago

Also, feature pointers are meant for, you know, pointing to features! not asking for permission to track data.

comment:3 @scribu3 years ago

Actually, only the PHP API is meant for internal use.

We don't stop plugins from enqueing the JS lib and using it, but if a lot of devs start abusing them, we will have to do something about it.

comment:4 @scribu3 years ago

  • Keywords dev-feedback added; close removed

I think this is a good signal to start thinking about offering a PHP API for this, possibly one that limits pop-ups to one per screen (as Yoast also suggested on twitter).

If I had my druthers, I'd remove them completely from Core, but you can't always have your druthers.

Last edited 3 years ago by scribu (previous) (diff)

comment:5 @scribu3 years ago

Previous discussion: 32:ticket:18693.

comment:6 follow-up: @azaozz3 years ago

This screenshot looks fine to me. If the user is bothered by plugins that show (too many) pointers, he/she can consider deleting the offending plugins.

The only thing I don't like is that a plugin added pointer can be without a "Dismiss" link/button.

comment:7 in reply to: ↑ 6 @mikeschinkel3 years ago

Replying to azaozz:

This screenshot looks fine to me. If the user is bothered by plugins that show (too many) pointers, he/she can consider deleting the offending plugins.

The only thing I don't like is that a plugin added pointer can be without a "Dismiss" link/button.

Agreed.

comment:8 @DrewAPicture2 years ago

  • Component changed from UI to Administration
  • Keywords ui-focus added

comment:9 @chriscct73 weeks ago

  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 3.4.1 to 3.4

This is more of an issue with the way a particular plugin decided to utilize a WordPress feature. WordPress should only be responsible for issues with pointers that are caused by WordPress core and it's own pointers. While WordPress in general can do things to prevent plugin authors from doing stupid things like ensuring sanitization on data entering the database or causing issues, there's no way WordPress can 100% prevent plugin authors from misusing features and unintentionally causing UX issues. As such, this doesn't seem to fall into the jurisdiction of a WordPress bug, its a bug of that plugin, and as such closing as invalid

comment:10 @SergeyBiryukov3 weeks ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.