WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 21 months ago

Last modified 21 months ago

#21842 closed defect (bug) (worksforme)

Diffrerent Custom Taxonomy Unable to Have Same Term Name in Version 3.4.2

Reported by: onetarek Owned by: oneTarek
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Taxonomy Keywords: reporter-feedback
Focuses: Cc:

Description

Before WordPress version 3.4.2 We know that WordPress does not support same word as category and tags. Assume you have a category named "iPhone" and it's slug is 'iphone' and now you want to add a new tag named "iPhone" , in this case tag slug will be 'iphone-2'. But if you have a custom taxonomy "Device" then the slug will be 'iphone' same as category "iphone". It means WordPress did not support same category and tag but can be same with any custom taxonomy. I tested many times this case.

But today after updating <a href="http://onetarek.com"><strong>My WordPress Blog</strong></a> to version 3.4.2 I found a mistake on it. I have 3 custom taxonomy. 'Type', 'Brand' and 'OS' . Before WP 3.4.2 I was able to use same word as Category and Type and also same slug for those. But now in version 3.4.2 when I am adding new terms It is getting slug with extra number 2. Example: I have a Category 'Apple' it's slug 'apple'. Now I am trying to add a 'Brand' taxonomy term 'Apple', the slug is being created 'apple-2'. But this problem was not in before WP 3.4.2

Change History (4)

comment:1 @scribu3 years ago

  • Keywords reporter-feedback needs-patch needs-testing removed

comment:2 @SergeyBiryukov3 years ago

  • Keywords reporter-feedback added; dev-feedback removed

Assume you have a category named "iPhone" and it's slug is 'iphone' and now you want to add a new tag named "iPhone" , in this case tag slug will be 'iphone-2'

Could not reproduce that neither in 3.3.2 nor in 3.4.2. My steps:

  1. Went to Categories screen, created "iPhone" category.
  2. Went to Tags screen, created "iPhone" tag.
  3. Both the category and the tag have "iphone" slug.

Have you tried disabling all plugins and switching to the default theme (Twenty Eleven)?

comment:3 @SergeyBiryukov21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Feel free to reopen with the steps to reproduce on a clean install if there's still a problem.

comment:4 @onetarek21 months ago

I tested this with a new fresh installation of WordPress-3.5.2
I don't see this problem now.

Note: See TracTickets for help on using tickets.