WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 19 months ago

Last modified 19 months ago

#21846 closed defect (bug) (invalid)

Blank captions don't work

Reported by: luffer Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Media Keywords:
Focuses: Cc:

Description

If you add a blank caption (space) to an image, it ignores the caption and doesn't frame the image.

What should happen is that a caption frame be added to the image with a blank space as the caption. Without this behaviour, there is no way to get a caption frame around images without adding a caption.

Change History (5)

comment:1 luffer20 months ago

NOTE: This was tested using the default theme with no plugins.

comment:2 greenshady20 months ago

I'd assume this is by design. You can't caption something without an actual caption. If you just want a specific design for your image, you should go with a custom image class and style it with CSS.

comment:3 Amit_k20 months ago

Completely agree with @greenshady, Also there is a filter - img_caption_shortcode, which can be used to enforce the caption div even if the caption field is empty.

comment:4 MikeHansenMe19 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I would agree as well.

comment:5 SergeyBiryukov19 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.