WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#21853 closed defect (bug) (worksforme)

Unable to Add Whitespace After Hyperlinks

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: major Version: 3.3.2
Component: Editor Keywords:
Focuses: Cc:

Description

This bug seems to have developed somewhere after version 3.1.

To reproduce this bug:

  1. Start a new post or page.
  2. Click the HTML tab.
  3. Paste this snippet:
<ul>
	<li><a href="http://www.google.com/">Parent item</a>SPACEME
		<ul>
			<li>Child item</li>
		</ul>
	</li>
</ul>
  1. Click the Visual tab and note how the hyperlink runs up against the word "SPACEME".
  2. Click the HTML tab.
  3. Add a space before "SPACEME".
  4. Click the Visual tab.
  5. Like magic, the space has vanished! :(

Curiously, I am unable to reproduce this behavior if I add the space on the Visual tab rather than the HTML tab. Very buggy!

Change History (5)

#1 @miqrogroove
9 years ago

Tested 3.4.2 with all plugins disabled, using Chrome 21, IE 8, Opera 12, Firefox 13, and found the same problem in all browsers.

#2 @ocean90
9 years ago

Confirmed in trunk.

#3 @nofearinc
9 years ago

The problem seems to exist only in a list when a submenu inside of a <li> has been defined.

#4 @miqrogroove
9 years ago

Thank you both for testing.

#5 @azaozz
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No longer happens in TinyMCE 4.0.

Note: See TracTickets for help on using tickets.